Encontrar primer y último mes con valores distintos a 0 – excel formulas

Pregunta:


Tengo la siguiente tabla en Excel:

| ID | Descripción | Año | Enero | Febrero | Marzo | Abril | Mayo | Junio | Julio | Agosto | Septiembre | Octubre | Noviembre | Diciembre |

En cada mes pueden existir valores entre el 0 y el 10.000. Lo que necesito saber es cuál es el primer y el último mes con valores distintos a cero.

Es decir, si tengo por ejemplo: Año 2015, y en los meses desde enero a marzo “0” luego desde abril a octubre valores distintos a 0 y finalmente de noviembre a diciembre 0 nuevamente, necesito que me muestre en otras 2 columnas:

Inicio = Abril | Fin = Octubre.

¿Es posible?

Edición: Para encontrar el primer distinto de 0 funciona esto:

=COINCIDIR(VERDADERO;D2:02>0;0))

Pero para el último todavía no se cómo hacer.

Preguntado por: Pepemujica

Suponiendo que tu tabla es así:

ID | Descripción | Año  | Enero | Febrero | Marzo | Abril | Mayo | Junio | Julio | Agosto | Septiembre | Octubre | Noviembre | Diciembre | Inicio       | Fin   
1  | Hola        | 2015 | 0     | 0       | 0     | 1     | 2    | 3     | 4     | 5      | 6          | 7       | 0         | 0         |              |
2  | Ciao        | 2016 | 0     | 0       | 3     | 4     | 5    | 6     | 7     | 8      | 9          | 0       | 0         | 0         |              |

Para obtener el primer mes podrías hacer algo como esto para Inicio:

=INDEX($D$1:$O$1,MATCH(TRUE,INDEX(D2:O2<>0,),0))

Y para el último mes algo como esto para Fin:

=INDEX($D$1:$O$1,MATCH(TRUE,INDEX(D2:O2<>0,),1))

(misma fórmula, sólo cambiando el tipo de coincidencia de 0 a 1). Aquí dejo una captura de pantalla de cómo se ve en mi Excel:

introducir la descripción de la imagen aquí

Lo siento, uso Excel en inglés, parece que los equivalentes en español serían INDICE para INDEX y COINCIDIR para MATCH, con lo que quedaría así:

=INDICE($D$1:$O$1,COINCIDIR(TRUE,INDICE(D2:O2<>0,),0))

=INDICE($D$1:$O$1,COINCIDIR(TRUE,INDICE(D2:O2<>0,),1))

La solución es una variante de la solución dada a esta respuesta en SuperUser.

Puedes utilizar la misma funcion ={COINCIDIR(VERDADERO;D2:02>0;0)}, solo debes cambiar el último cero por uno, para que te devuelva el último, {COINCIDIR(VERDADERO;D2:02>0;1)}

Fórmulas de matriz

NOTA: Luego de escribir la fórmula, oprimir CTRL + Mayúsculas + Intro

Inicio: =INDEX(C1:N1,,MIN(IF(C2:N2>0,COLUMN(C2:N2)-2,13)))

NOTA: Se ha indicado 13 como valor para FALSO asumiendo que siempre habrá un mes con un valor mayor que 0.

Fin: =INDEX(C1:N1,,MAX(IF(C2:N2>0,COLUMN(C2:N2)-2,0)))

NOTA: Se ha indicado 0 como valor para FALSO asumiendo que siempre habrá un mes con un valor mayor que 0.

Referencia

Fuente

Related Posts:

PHPExcel comentario en negro – php excel
Pregunta: Llevamos un tiempo usando PHPexcel para rellenar unas tablas desde la Base de Datos, lleva funcionando meses pero últimamente al escribir un comentario y ...
insertar un apostrofe antes de una consulta para excel – php mysql excel
Pregunta: Tengo este resultado de una consulta $consulta .= '<td>' . $v . '</td>'; donde la variable ' . $v . ' es un numero que contiene ...
Operaciones de fecha en Excel VBA – excel vba macros
Pregunta: me solicitaron a realizar un macro en VBA y se me está presentando un problema de que tengo que realizar una operación con fechas, ...
VBA Seleccionar elemento html por classe – excel vba macros
Pregunta: Necesito acceder a el valor de un input y hacer click en otro con una macro de Excel y necesito seleccionar los inputs mediante ...
C# formato de un celda en excel – c# excel numberformat
Pregunta: Necesito abrir un archivo de excel xlsx quitarle las comas a un par de celas para que pueda convertir el archivo en .csv. Quisero ...
¿Cómo leer un campo datetime de excel? – sql excel
Pregunta: Buenas tardes comunidad. Exporté una consulta de una tabla a excel, ahora quiero hacer un INSERT INTO de excel para SQL, investigando, encontré que el ...
Separar texto luego de un espacio, luego de otro caracter específico – excel mac-os microsoft-office
Pregunta: Necesito generar una fórmula de Excel para separar un texto de una dirección, tengo un libro de 2000 líneas que van de esta forma ...
Combinación de teclas para ir a la última celda con datos – excel
Pregunta: Tenemos una columna rellena con datos, p.e. de C2 hasta C20. Si me situo en cualquier posición de la hoja y pulso Control+Fin me ...
Error : No coinciden los tipos VBA – excel vba macros
Pregunta: Estoy haciendo una macro que compara dos columnas al mismo tiempo para realizar una operación, la columna A es de tipo Entero y la ...
Leer datos de Excel con Qt Creator – c++ excel qt
Pregunta: me gustaría saber como podría leer los datos de un excel desde una aplicación de Qt. Lo he intentado con el siguiente código pero ...
¿Cómo posicionar un JButton en Java? – java excel java-swing
Pregunta: Agradezco los comentarios, estoy familiarizándome con la página. He creado un boton pero necesito colocarlo en la parte superior izquierda de la pantalla, intente con ...
Desvincular dos gráficos dinámicos (modificar uno sin que afecte al otro) – excel
Pregunta: Buenas, tengo un par de problemas que agradecería bastante si alguien con mas experiencia en el asunto me puede ayudar. Contexto: Estoy creando un sistema ...
Como ejecutar una barra de carga cuando se esta ejecutando un macro? – excelexcel vba
Pregunta: Tengo un libro excel con capacidad de extraer datos de libros cerrados, como el proceso es lento quiero que mientras se ejecuta la extracción ...
¿Cómo puedo quitar columnheaders en un export a EXCEL? – java excel jasper-reports
Pregunta: Lo que trato de hacer es que se retire el columnheader del export en el subreporte en excel, solo quiero que aparezcan los datos, ...
¿Cómo exporto una tabla a un doc. excel desde un procedimiento almacenado en C#? – c# sql sql-server
Pregunta: Tengo mi procedimiento que trae una tabla y lo que quiero es que me lo exporte a Excel al presionar un botón. QUERY: CREATE PROC ...

Add a Comment

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *